Raporttipohjien muokkaaminen (Report Designer)

Report Designerillä voit suunnitella haluamasi raporttipohjan. Raporteissa voi käyttää kaikkia yleisiä muotoiluja sekä kuvia.

Report Designerin avaaminen

Helpoin tapa muokata Analystissä raportointiin käytettäviä raporttipohjia on suoraan Analystin Tuota raportti -paneelista. Klikkaa siellä kynä-ikonia, ympyröity oranssilla kuvassa:

Raportin valintanäkymä

Kenttien nimet joita käyttää raporttimuokkaimessa löytyvät klikkaamalla kynä-ikonin vieressä olevaa lista-ikonia. Tällöin aukeaa seuraavan näköinen ikkuna:

Tuloskentät ja kuvaajat Löydät erityisen testityypin kentät klikkaamalla listakuvaketta kynäikonin vieressä. Tämä toiminto näyttää juuri sillä hetkellä valitun testityypin erityiset kentät. Tämä auttaa sinua valitsemaan oikeat kentät raportillesi, varmistaen, että kaikki tiedot ovat relevantteja ja tarkkoja kyseisen testityypin osalta.

Report Designerin käynnistäminen suoraan

Report Designer -sovelluksen, jolla raportteja voi muokata, voi käynnistää seuraavasti.

  1. Avaa Käynnistä (Start) -valikko
  2. Avaa ForceProof-kansio
  3. Valitse Report Designer -pikakuvake.

Jos Report Designerin käynnistyessä sinulla ei ole jo raporttia auki, voit avata sen näin:

  1. Klikkaa File -> Open
  2. Valitse Dokumentit-kansio (Documents)
  3. Valitse ForceProof-kansio ja halutessasi vielä Examples-kansio
  4. Valitse raporttipohja, jonka haluat mukauttaa

Valmiin raporttipohjan käyttäminen pohjana

Kun Report Designer on auki, helpoin tapa tehdä uusia raporttipohjia, on avata olemassaolevista esimerkkipohjista yksi, ja muokata sitä. Tämä siksi, että esimerkkipohjissa on raporttien tuottamisvaiheessa täytettävät kentät jo valmiina.

Olemassaolevia kenttiä ja niiden ominaisuuksia voi muokata kaksoisklikkaamalla kenttää.

Raporttipohja avoimena Report Designerissä

Raporttipohjan muokkaamisen jälkeen voit tallentaa raporttipohjan uudella nimellä (File -> Save As...). Tallenna raporttipohjat käyttäjähakemistosi kansioon Dokumentit > ForceProof > Report Templates, niin ne ovat käytettävissä Analystissä.

Raporttipohjan muokkaaminen

  1. Oletustila. Klikkaa tätä kun haluat valita olemassaolevia elementtejä

  2. Teksti (Label). Lisää tekstiä raporttiin. Näkyy raporttipohjassa mustalla kehitettynä suorakulmiona, jossa lukee raportissa näytettävä teksti.

  3. Dynaaminen kenttä (Field). Kaikki tieto joka tulee ForceProofista raporttiin (ks. alla) lisätään kenttänä raporttipohjaan. Näkyy raporttipohjassa punaisella kehystettynä suorakulmiona, jossa lukee kentän nimi. Parametrien ja tulosarvojen yksiköt ja otsikot saa myös raporttipohjaan kirjoittamalla unit_arvonnimi tai label_arvonnimi. Näin on helppo varmistaa että vaikka arvon yksikkö tai otsikko muuttuisi joskus ForceProofissa, raporttipohja pysyy automaattisesti ajantasalla.

  4. Kuva (Image). Jos haluat lisätä oman logon raporttiin, klikkaa tätä.

  5. Taulukko (Table View). Monen kappaleen/tuloksen koontiraportissa olevaa taulukoitu tieto näytetään taulukossa.

  6. HTML. Jos raportteihin halutaan lisätä pidempiä muistiinpanoja sallivien tekstikenttien sisältöjä (tyypillisesti resultNotes-niminen kenttä), Report Designerissä käytetään Field-kentän sijaan HTML-kenttää, joka osaa näyttää myös muotoiltua tekstiä. Tiedät tarvitsevasi Field-kentän sijaan HTML-tyyppistä kenttää jos valmiissa raportissa kentän sisältö näyttää tämänkaltaiselta:

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
    <html><head><meta name="qrichtext" content="1" /><style>
    p, li { white-space: pre-wrap; }
    </style></head>
    

Uusien kenttien lisääminen: Yleiset tuloskentät

Numeerisen/desimaalilukukentän muotoilu Report Designer -sovelluksessa
Numeerisen/desimaalilukukentän muotoilu Report Designer -sovelluksessa
Numeerisen/desimaalilukukentän muotoilu Report Designer -sovelluksessa

Yhteiset kentät, kuten ‘projectName’, ‘author’, ja ‘date’, ovat aina käytettävissä kaikissa projekteissa, riippumatta projektityypistä. Nämä yleiset kentät tarjoavat jatkuvuutta ja standardointia raportointiin, varmistaen, että perustiedot ovat saatavilla jokaisessa raportissa.

Report Designerissä raporttipohjiin määritetään kentät, joiden arvot varsinaisessa raportissa halutaan näyttää.

Report Designerissä käytettävä kenttien Field Source Type on aina Parameter.

Raporttipohjissa voi käyttää seuraavia yleisiä projektikohtaisia kenttiä:

  • Projektin nimi: projectName
  • Testaajan nimi: author
  • Projektin luontipäivämäärä: date
  • Lisäkentät: extraField1, extraField2, jne. (lisäkentät otetaan käyttöön ja määritellään ForceProof Configure -sovelluksessa)

Lisäksi käytettävissä ovat aina seuraavat testikohtaiset kentät:

  • Monesko testi projektissa: resultIndexInProject
  • Testin kesto: testDuration (muodossa hh:mm:ss)
  • Testin aloituspäivämäärä ja -aika: testStartTime
  • Testin lopetuspäivämäärä ja -aika: testEndTime
  • Huomiot: resultNotes
  • Aloituspvm.: teststartdate
  • Testin lopetuspvm.: testenddate
  • Aloitusaika: teststartclocktime
  • Lopetusaika: testendclocktime

Uusien kenttien lisääminen: Testityyppikohtaiset tuloskentät

Kaikki projektille määritellyt parametri- ja tuloskentät ja niiden arvot ovat saatavilla raportointia varten.

Halutessasi lisätä uuden kentän arvon raporttiin, valitse NCReport Designerissä Insert -> Field. Piirrä sitten raporttiin hiirellä suorakulmio siihen kohtaan raporttia, johon uuden kentän haluat. Valitse Field source type -valintakentästä Parameter, ja riippuen haluamasi kentän sisällöstä Data type -valintakentästä haluamasi tietotyyppi - yleensä Numeric tai Text.

Numeric-tyyppiselle kentälle voit valita Insert Field -valintaikkunasta myös esimerkiksi desimaalien määrän.

Parametrikentät ovat "param_" -alkuisia. Kun käytät param_ -etuliitettä, saat raporttiin projektiparametrin testinaikaisen arvon, vaikka parametrin arvoa olisikin muokattu testin ajamisen jälkeen.

NCReport Designer-sovellukseen voit lisätä myös tietokenttiä, jotka sisältävät automaattisesti tuloskentän tai parametrikentän otsikon tai yksikön. Otsikkokentän etuliite on "label_" ja yksikön "unit_".

Esimerkiksi jos haluat lisätä "force" -nimisen kentän otsikon ja yksikön myös raporttiin, voit itse "force" -kentän lisäksi lisätä kentät "label_force" ja "unit_force", jolloin kentän otsikko ja yksikkö ovat automaattisesti aina yhdenmukaisia Testerissä ja Analystissä näkyvien otsikoiden kanssa.

Varsinaiset testin tuloskentät, joita raporttiin on saatavilla, ovat testityyppikohtaisia. Yleensä jokaista testityyppiä varten kannattaa siksi tehdä oma raporttipohjansa. (Osa kentistä, kuten kappaleen nimi ja mitat, ovat kappaletyyppikohtaisia.)

Tuloskentät sisältävät usein numeerisia arvoja. Raporttia tehdessä kenttää luodessa sen asetusruudusta kannattaa valita seuraavat asetukset. (Asetusruutuun pääsee kentän luonnin jälkeen kaksoisklikkaamalla kenttää. )

  • Valitse kentän tyypiksi Numeric
  • Numeric-välilehdestä raksita "Number formatting" ja "Blank if value equals zero"
  • Aseta "Decimal precision" -kohtaan desimaalien määrä, jonka haluat kentälle raporttiin.

Testityypissä saatavilla olevat asetusarvo- ja tulosarvokentät saa näkyville ForceProof Testerissä projektia luodessa, ja Analystissä raportoidessa.

Report Designer:ssä voi sen Field-tyyppisissä kentissä (merkitty raporttipohjassa punaisella pistekehyksellä) käyttää em. arvoja, jotka korvataan kulloinkin raportoitavan testin arvoilla raporttia tuotettaessa.

Lisätietoja

Jos tarvitset lisäksi muita tietoja raporttiisi, otathan yhteyttä ForceProof-toimittajaasi.

Lisätietoa Report Designer:n käytöstä on saatavilla Report Designer User's Guidesta (englanniksi):

  • NCReportin kotisivuilta josta löydät otteita alta suomeksi
  • Start/Käynnistä -valikossa ForceProofin ohjelmakansiossa löytyvästä Report Designer User's Guide -pikakuvakkeesta

 

Otteita raporttisovelluksen kehittyneemmästä dokumentaatiosta

Tarjoamme tämän suomenkielisen käännöksen raportointipaketin dokumentaatiosta, helpottaaksemme asiakkaidemme elämää erityistilanteissa. Kaikkia alla mainittuja toiminnallisuuksia ei välttämättä tueta virallisesti. Vielä laajempi dokumentaatio löytyy NCReportin kotisivuilta.

NCReportin ominaisuudet ja toiminnot:

  • Tuetut tulostusmuodot: Printer (Tulostin), Postscript, PDF, SVG, Text (Teksti), HTML, Image (Kuva)
  • Report elements: Label (Teksti), Field (Kenttä), HTML text (HTML-teksti), Line (Viiva), Rectangle (Suorakulmio), Ellipse (Ellipsi), Images (Kuvat), Barcode (Viivakoodi) ja Custom item (Mukautettu osio) graafeille tai QPainter-pohjaiselle sisällölle
  • Cross tabulation tables (Ristiintaulukointitaulukot)
  • Page header/footer (Sivun ylätunniste/alatunniste)
  • Report header/footer (Raportin ylätunniste/alatunniste)
  • Rajaton ryhmätasojen määrä ryhmien ylätunnisteilla, alatunnisteilla ja aggregaattitoiminnoilla: SUM, COUNT, AVERAGE, STANDARD DEVIATION, MIN, MAX
  • Aggregaattitoimintojen muuttujat, järjestelmämuuttujat
  • Kuvat: staattiset, tiedostosta, tietolähteestä tai HTTP-pohjaiset. Tiedostonimi voidaan myös hakea tietolähteestä
  • Skripti-ilmaisut kentille ja teksteille sekä loogiset ehdot
  • Kohteiden ja osioiden piilottaminen tai näyttäminen loogisten ehtojen perusteella
  • Ehdollinen Kenttä- tai Tekstiformaatti
  • Numeroiden, päivämäärien datan formaatti

Yksinkertaisen raportin luominen vaihe vaiheelta:

Uuden raportin aloittaminen: Avaa Report Designer (Raporttisuunnittelija) ja aloita uusi raportti napsauttamalla New (Uusi) työkalupalkin painiketta tai käyttämällä File (Tiedosto) → New (Uusi) -valikkoa.

Sivuasetusten määrittäminen: Nykyisen raportin sivuasetukset voidaan määrittää Report and Page settings (Raportti- ja Sivuasetukset) -dialogissa. Avaa Report (Raportti) -valikko ja valitse Report and Page options... (Raportti- ja Sivuasetukset...) -valikko. Tässä dialogissa voit määrittää seuraavat asetukset: Sivuasetukset

  • Report name (Raportin nimi): Kirjoita raportin nimi. Se on vain informatiivinen asetus, sitä ei käytetä raportin tuottamisessa.
  • Report type (Raportin tyyppi): Käytettävissä on kaksi raporttityyppiä. Raportti edustaa normaalia raporttia, Text document (Tekstidokumentti) on rajoitettu raporttitila. Tässä tilassa raportti voi sisältää vain HTML-tekstikohteita. Tuotettu raportti on sivutettu rikastekstidokumentti.
  • File encoding (Tiedoston koodaus): XML-tiedoston koodaus. Kun käyttäjä avaa tai tallentaa raportin määrittelytiedoston, tämä on oletuskoodaus. Useimmissa tapauksissa UTF-8 täyttää vaatimukset, mutta erityisille kansainvälisille merkeille voit valita minkä tahansa määritellyn koodauksen.
  • Default font (Oletusfontti): Fontin nimi ja koko
  • Page size (Sivukoko): Sivun koko. Kokonimien luettelo on lueteltu pudotusvalikossa, ja niiden nimet ovat standardikokojen nimet.
  • Background color (Taustaväri): Raportin taustaväri. Tämä asetus on tällä hetkellä käyttämätön.
  • Header and footer settings (Ylä- ja alatunnisteasetukset): Valintaruudut voidaan käyttää sivun ylä-/alatunnisteen ja raportin ylä-/alatunnisteen ottamiseen käyttöön tai poistamiseen käytöstä. Näiden osioiden korkeusominaisuuksien muuttamiseen voit käyttää näitä valintaruutuja vastaavia numerovalitsimia. Voit myös muuttaa näitä korkeusominaisuuksia hiirellä vetämällä tai geometriaeditorin avulla.
  • Margins (Marginaalit): Marginaalit edustavat sivun ylä-, ala-, vasen- ja oikeanpuoleisia marginaaleja millimetreinä. Marginaaliarvojen muuttamiseksi käytä vain numerovalitsimia.
  • Orientation (Suunta): Tämä valintapainikevaihtoehto edustaa sivun suuntaa. Voit valita Pysty- tai Vaakasuunnan.

Aseta sivun ominaisuudet tämän esimerkin mukaan ja napsauta OK-painiketta tietolähteen asetusten tallentamiseksi.

Tietolähteen lisääminen: Aluksi näet tyhjän uuden raportin, jossa on oletusarvoisesti sivun ylätunniste, yksityiskohta ja sivun alatunniste -osiot. Ennen raporttikohteiden lisäämistä määrittelemme tietolähteen, joka edustaa määritelmää siitä, mistä tiedot tulevat. Esimerkissämme tietolähde on Teksti.

  • Tietolähteen määrittämiseksi raporttiisi avaa Report (Raportti) -valikko ja valitse Data sources... (Tietolähteet...) -valikkokohta. Sitten ilmestyy dialogi, jossa voit lisätä ja/tai poistaa tietolähteitä. Uuden tietolähteen lisäämiseksi napsauta Add (Lisää) -painiketta dialogissa ja valitse sitten Text (Teksti) -tietolähteen tyyppi saatavilla olevien tietolähdetyyppien luettelosta.
  • Create (Luo) -painikkeen valitseminen avaa tietolähdedialogin ja lisää valitun tietolähde tyypin. Tietolähdedialogissa voit määritellä kaikki tietolähteen asetukset.

Yksityiskohtien osion tietolähteen määrittäminen: Määrittele aiemmin määritellyn tietolähteen yksityiskohtien osioon avaamalla Report (Raportti) -valikko ja valitsemalla Details and grouping... (Yksityiskohdat ja ryhmittely...) -valikkokohta, jonka jälkeen ilmestyy dialogi, jossa voit hallita raportin yksityiskohtien osioita. Oletusyksityiskohtien tunnus on Detail1, voit muuttaa sen mihin tahansa haluamaasi tunnukseen. Valitse aiemmin määritellyn tietolähteen tietolähdevalikosta.

Geometriaeditorin käyttäminen: Geometriaeditori on pieni työkaluikkuna suunnittelijassa objektien sijainnin ja koon näyttämiseen tai muokkaamiseen. Geometriaeditorin ottaminen käyttöön/poistaminen käytöstä tapahtuu View (Näkymä) -valikossa ja ottamalla käyttöön/poistamalla käytöstä Geometry editor (Geometriaeditori) -valikkokohdan.

Työkaluikkuna ilmestyy oikealle puolelle. Nykyiset objektit tai osiot aktivoidaan aina hiiren napsautuksella. Voit kirjoittaa numeeriset koko- tai sijaintiarvot numerovalitsimiin. Objektin ominaisuuksien muutokset päivittävät sen välittömästi.

Sivun ylätunnisteosion suunnittelu: Sivun ylätunnisteita käytetään sivun otsikoiden sisältämiseen. Lisäämme ensin sarakkeiden otsikot leimoina sivun ylätunnisteosioon. Leimat ovat yksinkertaisia tekstejä. Label (Leimat) ovat staattisia kohteita, niiden arvo ei koskaan muutu.

  • Leimojen lisääminen: Valitse Label (Leima) -työkalupainike tai valikkokohta Tools (Työkalut) -valikosta. Tämän jälkeen kursori muuttuu ristiviivaksi, sitten napsauta raportin määrittelyssä sivun ylätunnisteosiossa siinä kohdassa, jossa haluat Label (Leiman) sijaitsevan. Näin luot Label (Leima)-objektin kyseiseen osioon ja avaat Label settings (Leima-asetusten) dialogin.
  • Osioiden koon muuttaminen: Lisää sivun ylätunnisteosion korkeutta vetämällä osion alareunassa olevasta koonmuuttajapalkista. Toinen tapa koon muuttamiseen on kirjoittaa osion korkeusarvo Geometry editor (Geometriaeditoriin).
  • Viivan piirtäminen: Piirrä Line (Viiva) valitsemalla Line (Viiva) -painike työkalupalkista tai valikkokohta Tools (Työkalut) -valikosta. Tämän jälkeen kursori muuttuu ristiviivaksi, sitten napsauta raportin määrittelyssä siinä osiossa, jossa haluat Line (Viivan) alkavan ja vedä viiva loppuasentoon. Viivan siirtämiseksi vedä ja pudota sitä vasemmalla hiiren painikkeella.

Yksityiskohtien osion suunnittelu: Raportin ydininformaatio näytetään sen Detail (Yksityiskohtien) osiossa. Tämä osio on raportin tärkein osio, koska se sisältää riviriviltä tietoa tietolähteestä.

  • Kenttien lisääminen: Valitse Field (Kenttä) -työkalupainike tai valikkokohta Tools (Työkalut) -valikosta. Tämän jälkeen kursori muuttuu ristiviivaksi, sitten napsauta Detail (Yksityiskohtien) osiossa siinä kohdassa, jossa haluat Field (Kentän) sijaitsevan. Näin luot Field (Kenttä)-objektin kyseiseen osioon ja avaat Field settings (Kenttä-asetusten) dialogin.
  • Kentän ominaisuudet: Field source type (Kentän tietolähde), Field column/expression (Kentän sarake/ilmaisu), Data type (Tietotyyppi).
  • Field properties (Kenttien ominaisuudet): Ensimmäisen sarakkeen Field (Kenttä) -objektin ominaisuusdialogissa:
    • Lisää Fields (Kenttiä) Detail (Yksityiskohtien) osioon ja siirrä ne esimerkin mukaisiin paikkoihin. Field (Kenttä) sarakkeiden nimet ovat: col0, col1, col2, col3, col4, col5. Valitse col4 ja col5 -kentän kohteet ja aseta ne oikealle linjaamalla napsauttamalla Right alignment (Oikea linjaus) -työkalupainiketta. Sen jälkeen kentän dialogissa aseta Data type (Tietotyyppi) Numeriksi ja käytä Numeric (Numero) -välilehteä numeromuotoilun asetuksiin.
  • Resize the detail section (Muuta yksityiskohtien osion kokoa) 4,5 mm korkeuteen. Tämän jälkeen lisättyäsi myös Title label (Otsikkoleiman) Page header (Sivun ylätunniste) -osioon ja muotoiltuasi sen, raportin pitäisi näyttää tältä:

Sivun alatunnisteosion suunnittelu: Sivun alatunnistetta käytetään yleensä tietojen, kuten sivunumeron, näyttämiseen. Esimerkissämme lisäämme vain kaksi System variable fields (Järjestelmämuuttujakenttää): Application info (Sovellustiedot) ja Current page number (Nykyinen sivunumero).

  • Järjestelmämuuttujakenttien lisääminen: Valitse Field (Kenttä) -työkalupainike tai valikkokohta Tools (Työkalut) -valikosta. Tämän jälkeen kursori muuttuu ristiviivaksi, sitten napsauta Page footer (Sivun alatunniste) -osiossa siinä kohdassa, jossa haluat Field (Kentän) sijaitsevan. Näin luot Field (Kenttä)-objektin kyseiseen osioon ja avaat Field settings (Kenttä-asetusten) dialogin.
  • Adding page number field (Sivunumerokentän lisääminen): Määrittele kentän ominaisuudet tämän esimerkin mukaisesti:
    • Field source type (Kentän tietolähde): System variable (Järjestelmämuuttuja)
    • Field column/expression (Kentän sarake/ilmaisu): appinfo
  • Resize section (Osioiden koon muuttaminen): Pienennä Page footer (Sivun alatunniste) -osion korkeutta vetämällä osion alareunassa olevasta koonmuuttajapalkista. Toinen tapa koon muuttamiseen on kirjoittaa osion korkeusarvo Geometry editor (Geometriaeditoriin).
  • Asetusten asettamisen ja oikeisiin paikkoihin siirrettyjen kenttien jälkeen raportin pitäisi näyttää tältä:

Raportin testaaminen Suunnittelijassa: Malliraporttimme on nyt valmis testattavaksi. Raportin ajamiseen suunnittelijasta on vähintään kaksi tapaa: Valitse Report/Run report... (Raportti/Aja raportti...) -valikko ja raportin ajoikkunan ilmestyessä voit valita raportin tulosteen. Raportin ajamisen aloittamiseksi napsauta OK-painiketta.

  • Nopeaa esikatselua varten valitse vain Report/Run report to preview... (Raportti/Aja raportti esikatseluun...) -valikko ja sen jälkeen Suunnittelija ajaa raportin tulosteesikatseluun välittömästi. Tässä tilassa esimerkkiraporttimme esikatselu näyttää tältä:

Edistyneet askeleet: Seuraavassa osiossa kuvataan, kuinka käyttää joitakin NCReportin edistyneitä ominaisuuksia. Määrittelemme ryhmän ja sen jälkeen lisäämme yhteenvetomuuttujia esimerkkiraporttiimme.

  • Yhteenvetomuuttujan lisääminen: Variables (Muuttujat) ovat erityisiä numeerisia kohteita, joita käytetään lukumäärien ja yhteensumman tarjoamiseen. Jokaisella niistä on nimi, Function type (Toimintotyyppi), Data type (Tietotyyppi) ja ne on määritelty tietolähteen sarakkeeseen perustuviksi. Muuttujan lisäämiseksi avaa Report (Raportti) -valikko ja valitse Variables... (Muuttujat...) -valikkokohta. Sitten ilmestyy dialogi, jossa voit hallita muuttujia.
    • Muuttujan vaihtoehdot:
      • Variable ID (Muuttujan tunnus): Muuttujan nimi/tunnus
      • Variable expression (Muuttujan ilmaisu): Tietolähteen sarakkeen nimi, johon muuttuja perustuu
      • Function type (Toimintotyyppi): Muuttujan toimintotyyppi. Tuetut toimintotyypit: Sum (Summa), Count (Lasku)
      • Reset scope (Nollausalue): Määrittelee alueen, jonka jälkeen raporttimoottori nollaa muuttujan. Group level resets (Ryhmätason nollaukset) on myös asetettava ryhmäasetuksissa.
    • Initial value (Alkuperäinen arvo): Muuttujan alkuperäinen arvo

Ryhmän määrittely:

  • Raportit vaativat usein yhteenvetotietoja osion mukaan. Esimerkissämme lisäämme painon yhteenvedon tuoteryhmän mukaan raporttiin. Avaa ensin Report (Raportti) -valikko ja valitse Details and grouping... (Yksityiskohdat ja ryhmittely...) -valikkokohta, sitten ilmestyy dialogi, jossa voit hallita raportin yksityiskohtien osioita ja ryhmiä. Valitse Detail1 (Yksityiskohta1) -yksityiskohta ja napsauta Data grouping... (Datan ryhmittely...) -painiketta, jonka jälkeen Group settings (Ryhmäasetukset) -dialogi ilmestyy. Ryhmän ominaisuudet ovat saatavilla:
    • Group ID (Ryhmän tunnus): Ryhmän nimi/tunnus tunnistamistarkoituksiin
    • Group expression (Ryhmän ilmaisu): Tietolähteen sarakkeen nimi, johon ryhmä perustuu.
    • Header and Footer (Ylä- ja Alatunniste): Ottaaksesi ryhmän ylä-/alatunnisteen käyttöön tai poistaaksesi sen käytöstä, rastita tai poista rasti vastaavasta valintaruudusta. Näiden osioiden alkukorkeuden asettamiseen voit käyttää valintaruutujen vieressä olevia numerovalitsimia.
    • Reset variables (Nollaa muuttujat): Tämä lista sisältää 'Ryhmä' -alueen muuttujat. Voit määrittää, mitkä muuttujat raportin tuottaja nollaa, kun ryhmätaso loppuu.
  • Raportin ryhmittely perustuu tässä esimerkissä col0 sarakkeeseen (tuoteryhmäsarake). Määrittele ryhmän ominaisuudet tämän esimerkin mukaan:

Yhteenvetokentän lisääminen ryhmän alatunnisteeseen: - Lisätäksesi Field (Kenttä), joka perustuu var0-muuttujaan, lisää uusi Field (Kenttä) ryhmän alatunnisteeseen ja määrittele kentän ominaisuudet esimerkin mukaan.

© Copyright Scanrobot Oy & Fluxitek Oy